PPPoE dialin with a Cisco 871/876/878

The Cisco 871/876 is a small SOHO router with an integrated four-port switch on the LAN side.
On the WAN side, the C871 provides a Fastethernet interface for connecting an external xDSL-Modem, while C876/C878 have integrated xDSL-Modems available. C876 provides the ADSL Annex B flavor, the C878 offers an SHDSL-Modem.

Here are two templates for PPPoE dialin to an ISP.
Traffic from internal LAN is natted behind the public IP address assigned by the provider.

  • Cisco 871
interface Vlan1
 description internal LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 no shutdown
!
interface FastEthernet4
 description Link to xDSL-Modem
 no ip address
 pppoe-client dial-pool-number 1

 no shutdown
!
interface Dialer1
 description ISP DialIn
 ip address negotiated
 ip mtu 1492
 ip tcp adjust-mss 1452 
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname <username>
 ppp chap password 0 <password>
 ppp pap sent-username <username> password 0 <password>
!
ip nat inside source list 1 interface Dialer1 overload
access-list 1 remark NAT for internal LAN
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
  • Cisco 876/878
interface ATM0
 no ip address
 no atm ilmi-keepalive
 no shutdown
 pvc 1/32
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
 dsl enable-training-log
!
interface Vlan1
 description internal LAN
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 no shutdown
!
interface Dialer1
 description ISP DialIn
 ip address negotiated
 ip mtu 1492
 ip tcp adjust-mss 1452 
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname <username>
 ppp chap password 0 <password>
 ppp pap sent-username <username> password 0 <password>
!
ip nat inside source list 1 interface Dialer1 overload
access-list 1 remark NAT for internal LAN
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!

The value for the ATM PVC depends on the configuration of your line providers DSLAM.
PVC 1/32 is an often used value in Germany. In other european countries, PVC 0/35 and PVC8/35 are more common.

Troubleshooting

For forther investigation you can consult the following debug commads

  • debug ppp authentication
  • debug ppp negotiation
  • debug ppp error
  • debug pppoe events
  • debug pppoe packet (low level debugging)
  • debug atm events

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>